You are not logged in.

gorski

PurE2-Supporter

  • "gorski" is male
  • "gorski" started this thread

Posts: 527

Activitypoints: 5,925

Date of registration: Aug 12th 2017

net.hawkes.userlevel.level 33 [?]

net.hawkes.userlevel.experience 471,155

net.hawkes.userlevel.nextlevel 555,345

Thanks: 381 / 220

  • Send private message

1

Friday, January 26th 2018, 3:16pm

Open Multi Boot - if it works in your STB...

OpenMultiBoot - 1.0 2014/10/03

OpenMultiBoot will be donated to OE-Alliance by GigaBlue.
OpenMultiBoot can be modified or adapted to work with stb's from other vendors as long naming "openMultiBoot" is not changed and logos of openMultiBoot persists.
OpenMultiBoot uses boxbranding and informations from oe-alliance bitbake recipes. Due to that - ipk's are specific for each stb! Do not try to use OpenMultiBoot from stb A on stb B.
GigaBlue takes no responsibility for any potential damage openMultiBoot might cause on stb's from other vendors.
OpenMultiBoot requires some kernel-modules to work. They will be installed on installation of OpenMultiBoot.
ubifs - kernel-module-nandsim
jffs2 - kernel-module-nandsim kernel-module-block2mtd

(c) 2014 Impex-Sat GmbH & Co. KG - http://www.gigablue.de
Notes:

< device > has to be formated in ext4
< device > should be a fast usb-stick or ssd - not recommended to use a normal hdd as hdd would almost never stop spinning
Upload any zipped image to < device >/open-multiboot-upload or /omb/open-multiboot-upload
Zipped image needs regular folderstructure like flashing from usb-device
It is not recommended to re-use existing settings - do not blame us if problems occur
Check your recording path configuration and existing timers if you attach a new device
Do not use Flash-Online if you have not booted your regularly flashed image - use delete/install in OpenMultiBoot of regularly flashed image
Special thx goes to skaman, kajgan, captain, arn354 and all testers!



===========================================OK, NOW MY TAKE ON THINGS============================================

First, the context - what the "logic" of it all is...

Why OpenMultiBoot plugin (OMB from now on)? When do we need it - IF IT WORKS IN YOUR MACHINE?

OMB is advantageous when one's receiver has a very limited built-in flash memory! Then, one can install many more and bigger, more demanding images, too. One can also install many more plugins, tools, skins, picons and so on, than one usually can, if one is stuck with a small flash of one's Sat TV receiver.

So, there are 2 ways of installing an Enigma2 image in our satellite TV receivers:

- flash (built-in fixed memory of your receiver)

- USB device (such as a fast USB memory stick or USB SSD [never an HDD, since it has moving parts and it would spin all the time]).

Once one
- installs an E2 image into flash,
- mounts the USB device one will use for OMB, one must
- install the plugin itself (OMB) and then one can start installing more E2 images into the USB device.

PREPARATION:

a) Install E2 and then install the OMB plugin from MENU > PLUGINS > EXTENSIONS of your E2 image.

b) A USB device to use for OMB (a fast memory stick or SSD [never an HDD!]) has to be formatted in EXT4.

c) Connect the device to your box and mount it properly, using a good Device/Mount Manager.

Btw, a good Device Manager can also initialise, partition and format, not just mount the USB device.

Mount it as a "permanent mount", in FSTAB, if possible (one of the options during the mounting, as you will see).

HOW TO:

1) Using FileZilla Client, for instance, connect your PC with your Sat TV receiver and upload any zipped E2 image to /open-multiboot-upload or /omb/open-multiboot-upload folder.

2) Zipped E2 image must have a regular folder structure, as if one is flashing the image from a USB device.

3) DO NOT RESTORE SETTINGS from USB/HDD!!! Configure each and every new E2 from scratch, i.e. 'ab ovo', e.g. do it manually, step by step, do not use a 'shortcut'!

4) If you connect some new USB devices to your Sat TV receiver, then mount them carefully, i.e. set up your recording, timeshift, EPG, picons, buffering, downloading, subtitles etc. paths/folders one by one, with some forethought/planning! After that, check your existing timers, too. That way you will ensure that your E2 will be able to do whatever you are expecting from it.

5) Do not use Flash-Online if you have not booted your 'regularly flashed image'! I.e. you can use Flash-Online function only if you are in E2 that is installed in your flash! To (un)install new images in your USB device use delete/install in OpenMultiBoot of 'regularly flashed image', i.e. the E2 installed in your Flash!

Enjoy! smile

P.S. On F500HD, with that old kernel, I am stuck with the "Error: Cannot install kernel-module-block2mtd"...

P.P.S. The v. 2.5 is for OpenPLi, it is written/edited by Dimitrij and it only works on machines supported by OpenPLi!
gorski has attached the following files:
http://braungardt.trialectics.com/philos…/enlightenment/ - I. Kant, "Political writings" (1784), the jolly text on Enlightenment, at the basis of Modernity...

nyakec

Intermediate

Posts: 31

Activitypoints: 545

Date of registration: Oct 5th 2017

net.hawkes.userlevel.level 20 [?]

net.hawkes.userlevel.experience 26,048

net.hawkes.userlevel.nextlevel 29,658

Thanks: 16 / 61

  • Send private message

2

Monday, May 28th 2018, 11:45am

Please do not think about creating your own PureBoot VU + receiver? Well thank you

delfi

PurE2-Teamleiter

Posts: 1,090

Activitypoints: 13,770

Date of registration: Mar 14th 2013

net.hawkes.userlevel.level 42 [?]

net.hawkes.userlevel.experience 2,731,399

net.hawkes.userlevel.nextlevel 3,025,107

Thanks: 1097 / 543

  • Send private message

3

Monday, May 28th 2018, 5:39pm

I hope that openmultiboot works correctly. Are there any problems ?

1 registered user thanked already.

Users who thanked for this post:

nyakec (29.05.2018)

Stecheson

Trainee

Posts: 1

Activitypoints: 30

Date of registration: Apr 7th 2019

net.hawkes.userlevel.level 7 [?]

net.hawkes.userlevel.experience 292

net.hawkes.userlevel.nextlevel 443

Thanks: 2 / 3

  • Send private message

4

Sunday, January 12th 2020, 10:39pm

Works fine, no problem what so ever, I install BlackHole 3.9 but after one day I ask myself what the heck I need this when my Vu+ Uno4K SE works perfectly with PureE 6.3

2 registered users thanked already.

Users who thanked for this post:

gorski (13.01.2020), terrajoe (13.01.2020)

gorski

PurE2-Supporter

  • "gorski" is male
  • "gorski" started this thread

Posts: 527

Activitypoints: 5,925

Date of registration: Aug 12th 2017

net.hawkes.userlevel.level 33 [?]

net.hawkes.userlevel.experience 471,155

net.hawkes.userlevel.nextlevel 555,345

Thanks: 381 / 220

  • Send private message

5

Monday, January 13th 2020, 12:20am

-bier- :EVERYD~313: :12_small35: 1987r4tfg
http://braungardt.trialectics.com/philos…/enlightenment/ - I. Kant, "Political writings" (1784), the jolly text on Enlightenment, at the basis of Modernity...

1 user apart from you is browsing this thread:

1 guests

Similar threads